Mac OS X Catalina Not Compatible With Some Apps

Apple recently released Mac OS 10.15 Catalina. Catalina no longer supports 32-bit applications and users that install Catalina will no longer be able to install or run 32-bit applications. 

OIT recommends that Mac users ensure that their applications are compatible with Catalina prior to upgrading. 

Software that is known to not currently be compatible with Catalina includes:

If you need help determining whether a certain software title is compatible with your version of Mac OS X or need other assistance with your Mac, please contact the IT Help Desk.

More of Today's Announcements

There are currently no new announcements. Please check back later.

People in the News

montage photos of four people, a coloring sheet, a monster figurine, and lotion bottle
People | December 11, 2019
Still looking for some stocking stuffers? Check out the unique products from these UNLV grads.
Ryan Brunty leans against a large, furry version of his yeti
People | December 11, 2019
Ryan Brunty's melancholy, vulnerable yeti, Yerman, has become a sensation locally and online. Now it's making its way to Hot Topic.
woman holding colorful fabric
People | December 11, 2019
Alumna Jaimee Newberry turns a mommy-daughter holiday project into a booming custom clothing company.